[OpenSCAD] Problem with complex scad file

Don Bright hugh.m.bright at gmail.com
Thu Oct 20 00:11:41 CEST 2011


I had the same problem as you, when opening y-carriage2.scad

I ran 'top' to learn more: openscad uses 99% CPU for a few seconds,
then after printing "CSG Normalization" it rapidly gobbles up 800 M
RES and 990 M VIRT memory, and SWAP climbs into the high 70s M. Cpu
drops to about 5-10%.

I am running ubuntu 10 with 1 GB ram, openscad 2011.10.15

To run openscad without completely hard-locking my system I use ionice
+ nice, for example:

ionice -c 3 nice -n 19 openscad y-carriage2.scad

I am not sure of a workaround, other than breaking the part up into
smaller pieces... sorry

-DB


On Wed, Oct 19, 2011 at 2:26 PM, David Goodenough
<david.goodenough at linkchoose.co.uk> wrote:
> I have tried to load the main scad file from :-
>
> http://www.thingiverse.com/thing:12664
>
> in a directory with the included files, and got very odd
> behaviour from openscan.  I have tried this with openscad
> version 2011-09-30.
>
> I open the file, and then press F5.  Things start OK but then
> the lower right console screen stops scrolling, but the scroll
> bar indicates there is lots of stuff below it.  The machine
> then locks solid, and while I can interrupt it by switching
> to a console (Ctrl-Alt-F1) and killing it, but that is the
> only way.
>
> I have tried this on two different machines, both running Debian
> sid.
>
> Any ideas?
>
> David
> _______________________________________________
> OpenSCAD mailing list
> OpenSCAD at rocklinux.org
> http://rocklinux.net/mailman/listinfo/openscad
>


More information about the OpenSCAD mailing list