[OpenSCAD] ImplicitCAD 0.0.1

Christopher Olah christopherolah.co at gmail.com
Tue Feb 7 17:36:01 CET 2012


Another thought, you probably have to update sudo cabal separately...
Try sudo cabal update; sudo cabal install implicit ?

On Tue, Feb 7, 2012 at 11:33 AM, Christopher Olah
<christopherolah.co at gmail.com> wrote:
>>> The relevant option seems to be -L~/.cabal/lib . Alternatively, some
>>
>> Unfortunately that didn't work for me either
>
> Grr! Silly computer
>
>>> distros seem happier with sudo cabal install.
>>
>> I tried this too, and no love. I should have mentioned I am running 64-bit
>> Ubuntu 11.10. Actually this seems to have really messed up my cabal
>> database, now I can't cabal install without sudo, even after purging
>> cabal-install and rm -rf ~/.cabal
>
> Ubuntu seems to have strange cabal issues.
>
> Theoretically, cabal under sudo shouldn't be touching ~/.cabal -- that
> isn't even its home folder! Maybe try rm -rf /root/.cabal/ ?
>
> What error messages did cabal give?
>
> If you get it working, try -L/home/yournamehere/.cabal/lib , and maybe
> also -L ~/.cabal/lib in case the no space wasn't right.
>
>> Another update you may want to make while you're in there. Under the
>> instructions for installing from github, you say to run "cabal install", but
>> "cabal update" is needed first.
>
> D'oh! And I even had non-development one right!
>
> Still, not updating it till we have a fix. It seems my advice is
> making things worse!
>
>> No problem, thanks for writing it! :)
>
> No problem, I had an itch to scratch. :)


More information about the OpenSCAD mailing list