[OpenSCAD] Command line

nop head nop.head at gmail.com
Wed Feb 15 00:25:37 CET 2012


I'll see what I can do but I am insanely busy at the moment trying to
release Mendel90. I moved all the files to where I wanted them but I
couldn't make it work so I moved them all back as I have never had the
rules for picking up includes clear in my mind, even in C where I tend to
add "-I." I assumed the behaviour was correct and I was trying to do
something that would not work. When you said it should always be relative
to the file with the include I figured it should have worked but it is a
lot of editing and moving to put it back to the broken state.

Basically it was just a file that was included by files in different
directories and itself included other files. It behaved like its paths were
relative to the file that included it.

On 14 February 2012 21:05, Marius Kintel <marius at kintel.net> wrote:

> On Feb 14, 2012, at 21:44 PM, nop head wrote:
>
> > I had a file included from two different directories that was including
> files itself. I couldn't make it work because the path to those second
> level includes had to be different depending where it was included from. If
> the path was always relative to the file with the include statement that
> should have worked.
> >
> I'd be interested in any such non-working case to be able to automate
> these tests.
> To my knowledge, this works as expected.
>
>  -Marius
>
> _______________________________________________
> OpenSCAD mailing list
> OpenSCAD at rocklinux.org
> http://rocklinux.net/mailman/listinfo/openscad
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rocklinux.net/pipermail/openscad/attachments/20120215/71212674/attachment-0001.html


More information about the OpenSCAD mailing list