[OpenSCAD] Dependency changes

Don Bright hugh.m.bright at gmail.com
Mon Jan 9 04:55:41 CET 2012


Sorry... I just realized the bug patch I just submitted (fixing the
path bug) raises the dependency on boost to version 1.44, because of
the call to 'absolute()' (the OpenSCAD README says we require boost
1.35). The problem is, I'm not sure how to fix the bug without the
'absolute' function. And 'complete' was 'deprecated' somewhere in
boost 1.4x.0 if i am not mistaken.

Do you want me to try to backport some of the boost filesystem v3
stuff OpenSCAD needs to work with older boost? Or set up the OpenSCAD
build system to detect the boost version and throw a USE_DEPRECATED
switch with some #ifdefs? Or...?

-DB


More information about the OpenSCAD mailing list