[OpenSCAD] Problems importing STL models

W. Craig Trader craig.trader at gmail.com
Wed Mar 21 15:36:23 CET 2012


I've been printing parts for the local RepRap group, and as part of that
I've been using OpenSCAD to setup groups of objects to print together.
 Most of the models worked fine, or worked after being pushed through
NetFabb to clean them up, but I still have a couple of models that
individually can be sliced and printed (Skeinforge) but OpenSCAD/CGAL can't
handle importing and manipulating.

I've put all of the models and ancillary files up on GitHub (
https://github.com/wcraigtrader/novareprep-prusa-parts).  The specific
problems I'm having are with these parts:

module x_end_motor() {

import( "jason-models/x-end-motor-fixed.stl" );

}


module j_head_and_mg_mount() {

import( "jason-models/J-Head-and-MG-mount-fixed.stl" );

}


A typical error message would be:


Parsing design (AST generation)...

Compiling design (CSG Tree generation)...

Compilation finished.

Rendering Polygon Mesh using CGAL...

PolySetCache hit: cube(size=[105,105,0.25],center=true);

PolySetCache hit: cube(size=[104.5,104.5,0.5],center=true)

CGAL Cache insert: cube(size=[105,105,0.25],center=true); (10872 bytes)

CGAL Cache insert: cube(size=[104.5,104.5,0.5],center=true) (10872 bytes)

CGAL Cache insert: difference(){cube(size=[105,105,0.25],ce (21336 bytes)

PolySetCache hit: import(file="jason-models/x-end-motor-fi

CGAL error in CGAL_Build_PolySet: CGAL ERROR: assertion violation!

Expr: check_protocoll == 0

File: /usr/include/CGAL/Polyhedron_incremental_builder_3.h

Line: 198

CGAL Cache insert: import(file="jason-models/x-end-motor-fi (40 bytes)

CGAL Cache insert: group(){%multmatrix([[1,0,0,0],[0,1,0,0] (40 bytes)

CGAL Cache insert: group(){import(file="jason-models/x-end- (40 bytes)

CGAL Cache insert: group(){group(){%multmatrix([[1,0,0,0],[ (40 bytes)

PolySets in cache: 102

PolySet cache size in bytes: 2085192

CGAL Polyhedrons in cache: 528

CGAL cache size in bytes: 85761720

Total rendering time: 0 hours, 0 minutes, 0 seconds

WARNING: No top level geometry to render


If I'm reading the error correctly, it's happening when the
Polyhedron_incremental_builder_3 is being destroyed.


Thanks for any help you can suggest.


- Craig -
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rocklinux.net/pipermail/openscad/attachments/20120321/b209fa13/attachment.html


More information about the OpenSCAD mailing list