?mode=patch&uid=2010062917033728700
Open Patch: 2010062917033728700 (by stf)
+ stf
Votecheck 'core-strong': Missing 1 qualified vote(s) (clifford, fake, teha)
package/base/hal/hal.conf
Stefan Fiedler:
	hal: disable policykit support as it requires an old version

Stefan Fiedler:
	hal: disable policykit support as it requires an old version

--- package/base/hal/hal.conf	(revision 107)
+++ package/base/hal/hal.conf	(revision 108)
@@ -22,12 +22,16 @@
 
 var_append extraconfopt " " "--enable-verbose-mode"
 
-pkginstalled policykit || var_append extraconfopt " " "--disable-policy-kit"
+# hal does not seem to work with recent policykit
+var_append extraconfopt " " "--disable-policy-kit"
+
 pkginstalled parted && var_append extraconfopt " " "--enable-parted"
-if pkginstalled acl && pkginstalled attr ; then
-	var_append extraconfopt " " "--enable-acl-management"
-fi
 
+# old policykit is required for acl management
+#if pkginstalled acl && pkginstalled attr ; then
+#	var_append extraconfopt " " "--enable-acl-management"
+#fi
+
 hook_add postmake 3 "install_init hal $confdir/hal.init"
 
 # are these still needed without fstab sync?

[Download this patch]